Correzione: .NET Framework 4.7 non è supportato su questo sistema operativo

Consigli: Clicca Qui Per Correggere Gli Errori Di Windows E Ottimizzare Le Prestazioni Del Sistema

.Net Framework è un'infrastruttura di programmazione introdotta da Microsoft. Avrai bisogno di .Net Framework per eseguire diverse applicazioni e servizi. La maggior parte delle applicazioni che richiedono .Net Framework include anche i suoi file di installazione. Quindi, verrà automaticamente installato sul tuo sistema durante l'installazione di un'applicazione. Tuttavia, è possibile che venga visualizzato un errore ".NET Framework 4.7 non è supportato su questo sistema operativo" durante l'installazione di un'applicazione. Questo errore ti impedirà di installare correttamente l'applicazione. È possibile che venga visualizzato questo errore quando si tenta di installare .Net Framework come applicazione / servizio autonomo.

Il motivo per cui si verifica questo errore è lo stesso menzionato nel messaggio di errore. Anche se .Net Framework è supportato su Windows 10 ma non è compatibile con tutte le versioni di Windows 10. Quindi, se visualizzi questo messaggio, la causa più probabile di questo errore è che stai eseguendo una versione di Windows 10 che non è compatibile con .Net Framework.

Metodo 1: aggiorna Windows 10

L'unica soluzione per questo problema è semplicemente aggiornare Windows 10. Si consiglia di verificare gli aggiornamenti di Windows anche se si utilizza l'ultima versione di Windows 10. Poiché il problema è causato da un sistema operativo incompatibile, l'installazione di tutti i Windows 10 disponibili molto probabilmente gli aggiornamenti risolveranno il problema. Puoi anche controllare la versione esatta di Windows 10 e la versione richiesta da .Net Framework seguendo i passaggi indicati di seguito.

  1. Tenere premuto il tasto Windows e premere R
  2. Digita winver e premi Invio

  1. La tua versione dovrebbe essere menzionata nella finestra appena aperta. Il numero dopo la versione (nella seconda riga) è il tuo numero di versione. Il numero dovrebbe essere 1507 o 1709. Le prime 2 cifre sono l'anno e la seconda 2 rappresenta il mese. Quindi, se hai una versione 1709, ciò significa che stai eseguendo una versione rilasciata a settembre 2017

  1. Ora devi assicurarti di avere la versione di Windows 10 compatibile con .Net Framework. Fai clic qui e fai clic su Requisiti di sistema

Se dai un'occhiata alla sezione Sistema operativo supportato, si dice Aggiornamento dell'anniversario di Windows 10 e dell'aggiornamento di Windows 10 Creators . Poiché molte persone non hanno familiarità con i numeri di versione associati agli aggiornamenti Anniversary e Creators, li abbiamo citati di seguito

  • Aggiornamento di novembre (1511)
  • Aggiornamento anniversario (14393)
  • Creators Update (1703)
  • Fall Creators Update (1709)
  • Spring Creators Update (1803)

Come puoi vedere, l'aggiornamento dell'anniversario ha il numero di versione 14393 e l'aggiornamento dei creatori ha una versione 1703. Quindi, se hai una versione inferiore alla 14393, non sarai in grado di installare .Net Framework 4.7 su Windows 10. Ora aggiorna semplicemente Windows e assicurati di avere l'ultima versione di Windows 10 e riprova.

Articoli Interessanti